The current software most employees are already using should support MyQuickCoach content with no problem. If you'd like to make sure, here's what you need to know and/or share with your office information technology contact person.

To use MyQuickCoach, you need:

  • Access to the Internet with a minimum 56K connection speed
  • Windows Internet Explorer (version 5.0 or better)
    OR Netscape Navigator Browser (version 6 or better)
    OR Firefox (version 2.0 or better)
  • Macromedia Flash (version 7 or better)